openSUSE 10 Security Update : vim (vim-3410)

High Nessus Plugin ID 27474


The remote openSUSE host is missing a security update.


Files with VIM modelines could call some unsafe VIM functions (CVE-2007-2438). Modelines are disabled in the default config (/etc/vimrc) of openSUSE though.


Update the affected vim packages.

Plugin Details

Severity: High

ID: 27474

File Name: suse_vim-3410.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gvim, p-cpe:/a:novell:opensuse:vim, p-cpe:/a:novell:opensuse:vim-enhanced, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/05/24

Reference Information

CVE: CVE-2007-2438