openSUSE 10 Security Update : screen (screen-2198)

Low Nessus Plugin ID 27433


The remote openSUSE host is missing a security update.


A special formed UTF-8 sequence in text could be used to crash the terminal multitasker screen by overwriting memory in the heap. This is potentially exploitable to execute code. (CVE-2006-4573)


Update the affected screen package.

Plugin Details

Severity: Low

ID: 27433

File Name: suse_screen-2198.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:screen, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/10/24

Reference Information

CVE: CVE-2006-4573