openSUSE 10 Security Update : samba (samba-2553)

Medium Nessus Plugin ID 27427


The remote openSUSE host is missing a security update.


A logic error in the deferred open code can lead to an infinite loop in Samba's smbd daemon (CVE-2007-0452).

In addition the following changes are included with these packages :

- Move tdb utils to the client package.

- Add version of the package subversion to Samba vendor version suffix.

- Fix time value reporting in libsmbclient; [#195285].

- Store and restore NT hashes as string compatible values;

- Added winbindd null sid fix; [#185053].

- Fix from Alison Winters of SGI to build even if make_vscan is 0.

- Send correct workstation name to prevent NT_STATUS_INVALID_WORKSTATION beeing returned in samlogon; [#148645], [#161051].


Update the affected samba packages.

Plugin Details

Severity: Medium

ID: 27427

File Name: suse_samba-2553.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:samba, p-cpe:/a:novell:opensuse:samba-32bit, p-cpe:/a:novell:opensuse:samba-client, p-cpe:/a:novell:opensuse:samba-client-32bit, p-cpe:/a:novell:opensuse:samba-winbind, p-cpe:/a:novell:opensuse:samba-winbind-32bit, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/02/07

Reference Information

CVE: CVE-2007-0452