openSUSE 10 Security Update : rubygems (rubygems-2644)

High Nessus Plugin ID 27424


The remote openSUSE host is missing a security update.


This update fixes a vulnerability in rubygems that allowed to overwrite files with root privileges. (CVE-2007-0469)


Update the affected rubygems package.

Plugin Details

Severity: High

ID: 27424

File Name: suse_rubygems-2644.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygems, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/02/26

Reference Information

CVE: CVE-2007-0469