openSUSE 10 Security Update : ruby (ruby-2655)

Medium Nessus Plugin ID 27423


The remote openSUSE host is missing a security update.


The ruby package was updated to fix a denial of service problem in its CGI module when parsing multipart MIME messages. (CVE-2006-6303)


Update the affected ruby package.

Plugin Details

Severity: Medium

ID: 27423

File Name: suse_ruby-2655.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/03/01

Reference Information

CVE: CVE-2006-6303

CWE: 399