openSUSE 10 Security Update : qt3 (qt3-4421)

High Nessus Plugin ID 27415


The remote openSUSE host is missing a security update.


This update fixes a buffer overflow in qt3 while handling UTF8 characters. (CVE-2007-4137)


Update the affected qt3 packages.

Plugin Details

Severity: High

ID: 27415

File Name: suse_qt3-4421.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:qt3, p-cpe:/a:novell:opensuse:qt3-32bit, p-cpe:/a:novell:opensuse:qt3-devel, p-cpe:/a:novell:opensuse:qt3-devel-32bit, p-cpe:/a:novell:opensuse:qt3-devel-tools, p-cpe:/a:novell:opensuse:qt3-static, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/09/19

Reference Information

CVE: CVE-2007-4137

CWE: 119