openSUSE 10 Security Update : qt3 (qt3-3899)

Medium Nessus Plugin ID 27414


The remote openSUSE host is missing a security update.


Format string bugs in QTextEdit can be exploited via specially crafted HTML tags to potentially execute code (CVE-2007-3388).


Update the affected qt3 packages.

Plugin Details

Severity: Medium

ID: 27414

File Name: suse_qt3-3899.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:qt3, p-cpe:/a:novell:opensuse:qt3-32bit, p-cpe:/a:novell:opensuse:qt3-devel, p-cpe:/a:novell:opensuse:qt3-devel-32bit, p-cpe:/a:novell:opensuse:qt3-static, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/07/16

Reference Information

CVE: CVE-2007-3388