openSUSE 10 Security Update : postgresql (postgresql-3243)

High Nessus Plugin ID 27401


The remote openSUSE host is missing a security update.


This update fixes two vulnerabilities that affect the backend server and can only be exploited by authenticated users to cause a denial-of-service, or maybe to access other tables/databases without authentication. (CVE-2007-0555, CVE-2007-0556)


Update the affected postgresql packages.

Plugin Details

Severity: High

ID: 27401

File Name: suse_postgresql-3243.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql, p-cpe:/a:novell:opensuse:postgresql-contrib, p-cpe:/a:novell:opensuse:postgresql-devel, p-cpe:/a:novell:opensuse:postgresql-libs, p-cpe:/a:novell:opensuse:postgresql-libs-32bit, p-cpe:/a:novell:opensuse:postgresql-pl, p-cpe:/a:novell:opensuse:postgresql-server, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/04/30

Reference Information

CVE: CVE-2007-0555, CVE-2007-0556