openSUSE 10 Security Update : postgresql (postgresql-1443)

High Nessus Plugin ID 27400


The remote openSUSE host is missing a security update.


This update fixes a security problem that allowed attackers to inject SQL commands into queries (CVE-2006-2313, CVE-2006-2314).


Update the affected postgresql packages.

Plugin Details

Severity: High

ID: 27400

File Name: suse_postgresql-1443.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql, p-cpe:/a:novell:opensuse:postgresql-contrib, p-cpe:/a:novell:opensuse:postgresql-devel, p-cpe:/a:novell:opensuse:postgresql-libs, p-cpe:/a:novell:opensuse:postgresql-libs-32bit, p-cpe:/a:novell:opensuse:postgresql-pl, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/05/29

Reference Information

CVE: CVE-2006-2313, CVE-2006-2314