openSUSE 10 Security Update : pfstools (pfstools-4083)

Medium Nessus Plugin ID 27388


The remote openSUSE host is missing a security update.


A buffer overflow when processing RGBE file could potentially allow attackers to execute arbitrary code by tricking the victim into running 'pfsinrgbe' on a specially crafted file (CVE-2007-2956).


Update the affected pfstools package.

Plugin Details

Severity: Medium

ID: 27388

File Name: suse_pfstools-4083.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:pfstools, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/08/14

Reference Information

CVE: CVE-2007-2956