openSUSE 10 Security Update : opera (opera-2456)

High Nessus Plugin ID 27375


The remote openSUSE host is missing a security update.


This update brings the Opera Webbrowser to version 9.10, fixing following 2 security problems :

- Opera processes a JPEG DHT marker incorrectly, which can potentially lead to remote code execution.

- Opera is affected by a typecasting bug in its Javascripts SVG implementation which could potentially be used to execute code.


Update the affected opera package.

Plugin Details

Severity: High

ID: 27375

File Name: suse_opera-2456.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:opera, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/01/10