openSUSE 10 Security Update : openssh (openssh-2256)

High Nessus Plugin ID 27366


The remote openSUSE host is missing a security update.


The OpenSSH release 4.5 contains a security fix which has been backported to the openssh versions in our old products.

CVE-2006-5794: Incorrect return argument checking in the privilege separation monitor was fixed. In case of an exploitable unprivileged helper this could have been used to elevate privileges.


Update the affected openssh packages.

Plugin Details

Severity: High

ID: 27366

File Name: suse_openssh-2256.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:openssh, p-cpe:/a:novell:opensuse:openssh-askpass, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/11/10

Reference Information

CVE: CVE-2006-5794