openSUSE 10 Security Update : mysql (mysql-1593)

High Nessus Plugin ID 27357


The remote openSUSE host is missing a security update.


This update of mysql fixes a bug in the mysql_real_escape() function that allowed SQL command injection (CVE-2006-2753).


Update the affected mysql packages.

Plugin Details

Severity: High

ID: 27357

File Name: suse_mysql-1593.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:opensuse:mysql-Max, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/06/09

Reference Information

CVE: CVE-2006-2753