openSUSE 10 Security Update : mailman (mailman-2170)

High Nessus Plugin ID 27344


The remote openSUSE host is missing a security update.


This update of mailman fixes the following security issues :

- A malicious user could visit a specially crafted URI and inject an apparent log message into Mailman's error log which might induce an unsuspecting administrator to visit a phishing site. This has been blocked. Thanks to Moritz Naumann for its discovery.

- Fixed denial of service attack which can be caused by some standards-breaking RFC 2231 formatted headers.

- Several cross-site scripting issues have been fixed.
Thanks to Moritz Naumann for their discovery.

- Fixed an unexploitable format string vulnerability.
Discovery and fix by Karl Chen. Analysis of non-exploitability by Martin 'Joey' Schulze. Also thanks go to Lionel Elie Mamane. CVE-2006-2191.


Update the affected mailman package.

Plugin Details

Severity: High

ID: 27344

File Name: suse_mailman-2170.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mailman, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/10/13

Reference Information

CVE: CVE-2006-2191, CVE-2006-2941, CVE-2006-3636