openSUSE 10 Security Update : libpng (libpng-2322)

High Nessus Plugin ID 27329


The remote openSUSE host is missing a security update.


The sPLT chunk handling in libpng was incorrect and a handcrafted PNG file could be use to cause an out-of-bounds read, effectively crashing the PNG viewer or webbrowser. (CVE-2006-5793)

Additionaly a 2 byte stackoverflow was fixed which we do not believe to be exploitable. It will cause an abort of the viewer or webbrowser in SUSE Linux 10.0 and newer due to string overflow checking.


Update the affected libpng packages.

Plugin Details

Severity: High

ID: 27329

File Name: suse_libpng-2322.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpng, p-cpe:/a:novell:opensuse:libpng-32bit, p-cpe:/a:novell:opensuse:libpng-devel, p-cpe:/a:novell:opensuse:libpng-devel-32bit, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/11/30

Reference Information

CVE: CVE-2006-3334, CVE-2006-5793