openSUSE 10 Security Update : libarchive (libarchive-3982)

High Nessus Plugin ID 27316

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted tar-archives could cause programs based on libarchive to crash, to run into an enless loop or potentially to even execute arbitrary code (CVE-2007-3641, CVE-2007-3644, CVE-2007-3645).

Solution

Update the affected libarchive packages.

Plugin Details

Severity: High

ID: 27316

File Name: suse_libarchive-3982.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2007/10/17

Updated: 2018/07/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bsdtar, p-cpe:/a:novell:opensuse:libarchive, p-cpe:/a:novell:opensuse:libarchive-devel, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/07/30

Reference Information

CVE: CVE-2007-3641, CVE-2007-3644, CVE-2007-3645