openSUSE 10 Security Update : ktorrent (ktorrent-3057)

High Nessus Plugin ID 27314


The remote openSUSE host is missing a security update.


Ktorrent insufficiently validated the target file name. A malicious Server could therefore overwrite arbitary files of the user (CVE-2007-1384,CVE-2007-1799). Another bug could be exploited to crash Ktorrent (CVE-2007-1385).


Update the affected ktorrent package.

Plugin Details

Severity: High

ID: 27314

File Name: suse_ktorrent-3057.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ktorrent, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/04/03

Reference Information

CVE: CVE-2007-1384, CVE-2007-1385, CVE-2007-1799