openSUSE 10 Security Update : kdelibs3 (kdelibs3-3058)

Medium Nessus Plugin ID 27289


The remote openSUSE host is missing a security update.


A bug in KHTML could be exploited to conduct cross site scripting (XSS) attacks (CVE-2007-0537).

Another bug allowed attackers to abuse the FTP passive mode for portscans (CVE-2007-1564).


Update the affected kdelibs3 packages.

Plugin Details

Severity: Medium

ID: 27289

File Name: suse_kdelibs3-3058.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kdelibs3, p-cpe:/a:novell:opensuse:kdelibs3-32bit, p-cpe:/a:novell:opensuse:kdelibs3-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/04/03

Reference Information

CVE: CVE-2007-0537, CVE-2007-1564

CWE: 79