openSUSE 10 Security Update : kdegraphics3-pdf (kdegraphics3-pdf-3972)

Medium Nessus Plugin ID 27288


The remote openSUSE host is missing a security update.


A buffer overflow in the xpdf code contained in kpdf could be exploited by attackers to potentially execute arbitrary code (CVE-2007-3387).


Update the affected kdegraphics3-pdf package.

Plugin Details

Severity: Medium

ID: 27288

File Name: suse_kdegraphics3-pdf-3972.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kdegraphics3-pdf, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/26

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-3387

CWE: 189