openSUSE 10 Security Update : kdebase3 (kdebase3-3347)

Medium Nessus Plugin ID 27284


The remote openSUSE host is missing a security update.


A problem with the interaction between the Flash Player and the Konqueror webbrowser was fixed. The problem could lead to keypresses leaking to the applet instead of the browser. (CVE-2007-2022)

This update of khc_indexbuilder restricts the commands that can be executed with EGID 'man'.


Update the affected kdebase3 packages.

Plugin Details

Severity: Medium

ID: 27284

File Name: suse_kdebase3-3347.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kdebase3, p-cpe:/a:novell:opensuse:kdebase3-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/05/11

Reference Information

CVE: CVE-2007-2022

CWE: 200