openSUSE 10 Security Update : gpg (gpg-2388)

Critical Nessus Plugin ID 27247


The remote openSUSE host is missing a security update.


- Specially crafted files could overflow a buffer when gpg was used in interactive mode (CVE-2006-6169).

- Specially crafted files could modify a function pointer and execute code this way (CVE-2006-6235).


Update the affected gpg packages.

Plugin Details

Severity: Critical

ID: 27247

File Name: suse_gpg-2388.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gpg, p-cpe:/a:novell:opensuse:gpg2, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/12/07

Reference Information

CVE: CVE-2006-6169, CVE-2006-6235