openSUSE 10 Security Update : gimp (gimp-3995)

Medium Nessus Plugin ID 27237


The remote openSUSE host is missing a security update.


Multiple gimp import filters contained integer overflows. Attackers could exploit that to potentially execute code by tricking users into opening specially crafted files (CVE-2006-4519).


Update the affected gimp packages.

Plugin Details

Severity: Medium

ID: 27237

File Name: suse_gimp-3995.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gimp, p-cpe:/a:novell:opensuse:gimp-devel, p-cpe:/a:novell:opensuse:gimp-unstable, p-cpe:/a:novell:opensuse:gimp-unstable-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/07/30

Reference Information

CVE: CVE-2006-4519

CWE: 189