openSUSE 10 Security Update : gd (gd-3896)

Medium Nessus Plugin ID 27231


The remote openSUSE host is missing a security update.


This update fixes multiple integer overflows in the gd library.
Specially crafted files could leverage them to at least crash gd based applications (CVE-2007-3472, CVE-2007-3475, CVE-2007-3476, CVE-2007-3477, CVE-2007-3478).


Update the affected gd packages.

Plugin Details

Severity: Medium

ID: 27231

File Name: suse_gd-3896.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gd, p-cpe:/a:novell:opensuse:gd-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/07/16

Reference Information

CVE: CVE-2007-3472, CVE-2007-3475, CVE-2007-3476, CVE-2007-3477, CVE-2007-3478

CWE: 189, 362, 399