openSUSE 10 Security Update : freetype2 (freetype2-1910)

High Nessus Plugin ID 27225


The remote openSUSE host is missing a security update.


This security update fixes crashes in the PCF handling of freetype2 which might be used to crash freetype2 using applications or even to execude code in them.

This issue is tracked by the Mitre CVE ID CVE-2006-3467.


Update the affected freetype2 packages.

Plugin Details

Severity: High

ID: 27225

File Name: suse_freetype2-1910.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:freetype2, p-cpe:/a:novell:opensuse:freetype2-32bit, p-cpe:/a:novell:opensuse:freetype2-devel, p-cpe:/a:novell:opensuse:freetype2-devel-32bit, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/07/26

Reference Information

CVE: CVE-2006-3467