openSUSE 10 Security Update : flash-player (flash-player-2072)

Medium Nessus Plugin ID 27219


The remote openSUSE host is missing a security update.


Multiple input validation errors have been identified in Flash Player that could lead to the potential execution of arbitrary code. These vulnerabilities could be accessed through content delivered from a remote location via the user's web browser, email client, or other applications that include or reference the Flash Player.
(CVE-2006-3311, CVE-2006-3587, CVE-2006-3588)

These updates include changes to prevent circumvention of the 'allowScriptAccess' option. (CVE-2006-4640)


Update the affected flash-player package.

Plugin Details

Severity: Medium

ID: 27219

File Name: suse_flash-player-2072.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/09/13

Reference Information

CVE: CVE-2006-3311, CVE-2006-3587, CVE-2006-3588, CVE-2006-4640

CWE: 264