openSUSE 10 Security Update : file (file-3449)

High Nessus Plugin ID 27215


The remote openSUSE host is missing a security update.


This update fixes an integer overflow in function file_printf() of file. This bug can be used to execute arbitrary code.


Update the affected file packages.

Plugin Details

Severity: High

ID: 27215

File Name: suse_file-3449.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:file, p-cpe:/a:novell:opensuse:file-32bit, p-cpe:/a:novell:opensuse:file-devel, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/05/25