openSUSE 10 Security Update : bind (bind-2529)

High Nessus Plugin ID 27167


The remote openSUSE host is missing a security update.


A security problem was fixed in the ISC BIND nameserver version 9.3.4, these are addressed by this security update.

If recursion is enabled, a remote attacker can dereference a freed fetch context causing the daemon to abort / crash.


Update the affected bind packages.

Plugin Details

Severity: High

ID: 27167

File Name: suse_bind-2529.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bind, p-cpe:/a:novell:opensuse:bind-libs, p-cpe:/a:novell:opensuse:bind-libs-32bit, p-cpe:/a:novell:opensuse:bind-utils, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/01/25