openSUSE 10 Security Update : avahi (avahi-2982)

Medium Nessus Plugin ID 27161


The remote openSUSE host is missing a security update.


This update fixes a remote denial of service problem in avahi, where attackers could cause an endless loop. (CVE-2006-6870)


Update the affected avahi packages.

Plugin Details

Severity: Medium

ID: 27161

File Name: suse_avahi-2982.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:avahi, p-cpe:/a:novell:opensuse:avahi-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/03/21

Reference Information

CVE: CVE-2006-6870