openSUSE 10 Security Update : MozillaFirefox (MozillaFirefox-2090)

Critical Nessus Plugin ID 27114

Synopsis

The remote openSUSE host is missing a security update.

Description

This security update brings Mozilla Firefox to version 1.5.0.7.

Please also see http://www.mozilla.org/projects/security/known-vulnerabilities.html for more details.

It fixes the following security problems: MFSA 2006-64/CVE-2006-4571:
Crashes with evidence of memory corruption MFSA 2006-62/CVE-2006-4569:
Popup-blocker cross-site scripting (XSS) MFSA 2006-61/CVE-2006-4568:
Frame spoofing using document.open() MFSA 2006-60/CVE-2006-4340/CERT VU#845620: RSA Signature Forgery MFSA 2006-59/CVE-2006-4253:
Concurrency-related vulnerability MFSA 2006-58/CVE-2006-4567:
Auto-Update compromise through DNS and SSL spoofing MFSA 2006-57/CVE-2006-4565/CVE-2006-4566: JavaScript Regular Expression Heap Corruption

Solution

Update the affected MozillaFirefox packages.

See Also

http://www.mozilla.org/projects/security/known-vulnerabilities.html

Plugin Details

Severity: Critical

ID: 27114

File Name: suse_MozillaFirefox-2090.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2007/10/17

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaFirefox, p-cpe:/a:novell:opensuse:MozillaFirefox-translations, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/09/15

Reference Information

CVE: CVE-2006-4253, CVE-2006-4340, CVE-2006-4565, CVE-2006-4566, CVE-2006-4567, CVE-2006-4568, CVE-2006-4569, CVE-2006-4571

CWE: 20, 79, 119, 264