openSUSE 10 Security Update : GraphicsMagick (GraphicsMagick-3129)

High Nessus Plugin ID 27103


The remote openSUSE host is missing a security update.


This update of GraphicsMagick fixes three integer overflow in DCM and XWD code. These bugs can be exploited remotely via other application.


Update the affected GraphicsMagick packages.

Plugin Details

Severity: High

ID: 27103

File Name: suse_GraphicsMagick-3129.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:GraphicsMagick, p-cpe:/a:novell:opensuse:GraphicsMagick-c++, p-cpe:/a:novell:opensuse:GraphicsMagick-c++-devel, p-cpe:/a:novell:opensuse:GraphicsMagick-devel, p-cpe:/a:novell:opensuse:perl-GraphicsMagick, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/04/19

Reference Information

CVE: CVE-2007-1667, CVE-2007-1797

CWE: 189