FreeBSD : tcl/tk -- buffer overflow in ReadImage function (a058d6fa-7325-11dc-ae10-0016179b2dd5)

medium Nessus Plugin ID 26938
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

A Buffer overflow in the ReadImage function in generic/tkImgGIF.c in Tcl/Tk, allows remote attackers to execute arbitrary code via multi-frame interlaced GIF files in which later frames are smaller than the first.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?90d23187

http://www.nessus.org/u?6c826568

Plugin Details

Severity: Medium

ID: 26938

File Name: freebsd_pkg_a058d6fa732511dcae100016179b2dd5.nasl

Version: 1.19

Type: local

Published: 10/9/2007

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:tk, p-cpe:/a:freebsd:freebsd:tk-threads, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 10/5/2007

Vulnerability Publication Date: 9/27/2007

Reference Information

CVE: CVE-2007-5137

Secunia: 26942

CWE: 119