FreeBSD : firebird -- multiple remote buffer overflow vulnerabilities (91ed69f9-72c7-11dc-981a-001921ab2fa4)

Critical Nessus Plugin ID 26937


The remote FreeBSD host is missing one or more security-related updates.


RISE Security reports :

There exists multiple vulnerabilities within functions of Firebird Relational Database, which when properly exploited can lead to remote compromise of the vulnerable system.


Update the affected packages.

See Also

Plugin Details

Severity: Critical

ID: 26937

File Name: freebsd_pkg_91ed69f972c711dc981a001921ab2fa4.nasl

Version: $Revision: 1.21 $

Type: local

Published: 2007/10/09

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:firebird-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/10/04

Vulnerability Publication Date: 2007/10/03

Reference Information

CVE: CVE-2007-5245, CVE-2007-5246

BID: 25925

CWE: 119