FreeBSD : apache -- multiple vulnerabilities (c115271d-602b-11dc-898c-001921ab2fa4)

Medium Nessus Plugin ID 26039


The remote FreeBSD host is missing one or more security-related updates.


Apache HTTP server project reports :

The following potential security flaws are addressed :

- CVE-2007-3847: mod_proxy: Prevent reading past the end of a buffer when parsing date-related headers.

- CVE-2007-1863: mod_cache: Prevent a segmentation fault if attributes are listed in a Cache-Control header without any value.

- CVE-2007-3304: prefork, worker, event MPMs: Ensure that the parent process cannot be forced to kill processes outside its process group.

- CVE-2006-5752: mod_status: Fix a possible XSS attack against a site with a public server-status page and ExtendedStatus enabled, for browsers which perform charset 'detection'. Reported by Stefan Esser.

- CVE-2006-1862: mod_mem_cache: Copy headers into longer lived storage; header names and values could previously point to cleaned up storage.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 26039

File Name: freebsd_pkg_c115271d602b11dc898c001921ab2fa4.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/09/14

Modified: 2013/07/20

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:apache, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/09/11

Vulnerability Publication Date: 2007/09/07

Reference Information

CVE: CVE-2006-5752, CVE-2007-1863, CVE-2007-3304, CVE-2007-3847