GLSA-200708-13 : BIND: Weak random number generation

Medium Nessus Plugin ID 25919


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200708-13 (BIND: Weak random number generation)

Amit Klein from Trusteer reported that the random number generator of ISC BIND leads, half the time, to predictable (1 chance to 8) query IDs in the resolver routine or in zone transfer queries (CVE-2007-2926).
Additionally, the default configuration file has been strengthen with respect to the allow-recursion{} and the allow-query{} options (CVE-2007-2925).
Impact :

A remote attacker can use this weakness by sending queries for a domain he handles to a resolver (directly to a recursive server, or through another process like an email processing) and then observing the resulting IDs of the iterative queries. The attacker will half the time be able to guess the next query ID, then perform cache poisoning by answering with those guessed IDs, while spoofing the UDP source address of the reply. Furthermore, with empty allow-recursion{} and allow-query{} options, the default configuration allowed anybody to make recursive queries and query the cache.
Workaround :

There is no known workaround at this time for the random generator weakness. The allow-recursion{} and allow-query{} options should be set to trusted hosts only in /etc/bind/named.conf, thus preventing several security risks.


All ISC BIND users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-dns/bind-9.4.1_p1'

See Also

Plugin Details

Severity: Medium

ID: 25919

File Name: gentoo_GLSA-200708-13.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/08/21

Modified: 2015/08/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:bind, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/08/18

Vulnerability Publication Date: 2007/07/24

Reference Information

CVE: CVE-2007-2925, CVE-2007-2926

OSVDB: 36235, 36236

GLSA: 200708-13