FreeBSD : libvorbis -- Multiple memory corruption flaws (b73335a5-3bbe-11dc-8e83-0016179b2dd5)

Medium Nessus Plugin ID 25786


The remote FreeBSD host is missing a security-related update.


isecpartners reports :

libvorbis contains several vulnerabilities allowing heap overwrite, read violations and a function pointer overwrite. These bugs cause a at least a denial of service, and potentially code execution.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 25786

File Name: freebsd_pkg_b73335a53bbe11dc8e830016179b2dd5.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2007/07/27

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libvorbis, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/07/26

Vulnerability Publication Date: 2007/06/05

Reference Information

CVE: CVE-2007-3106

CWE: 399