MySQL Community Server 5.0 < 5.0.45 Multiple Vulnerabilities

medium Nessus Plugin ID 25759
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is susceptible to multiple attacks.

Description

The version of MySQL Community Server installed on the remote host is reportedly affected by a denial of service vulnerability that can lead to a server crash with a specially crafted password packet.

It is also affected by a privilege escalation vulnerability because 'CREATE TABLE LIKE' does not require any privileges on the source table, which allows an attacker to create arbitrary tables using the affected application.

Solution

Upgrade to MySQL Community Server version 5.0.45 or later.

See Also

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-45.html

Plugin Details

Severity: Medium

ID: 25759

File Name: mysql_5_0_45.nasl

Version: 1.22

Type: remote

Family: Databases

Published: 7/25/2007

Updated: 7/16/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 1/13/2007

Reference Information

CVE: CVE-2007-3780, CVE-2007-3781, CVE-2007-3782

BID: 25017

CWE: 20, 264