GLSA-200707-02 : Two buffer overflows

High Nessus Plugin ID 25660


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200707-02 ( Two buffer overflows)

John Heasman of NGSSoftware has discovered a heap-based buffer overflow when parsing the 'prdata' tag in RTF files where the first token is smaller than the second one (CVE-2007-0245). Additionally, the OpenOffice binary program is shipped with a version of FreeType that contains an integer signedness error in the n_points variable in file truetype/ttgload.c, which was covered by GLSA 200705-22 (CVE-2007-2754).
Impact :

A remote attacker could entice a user to open a specially crafted document, possibly leading to execution of arbitrary code with the rights of the user running
Workaround :

There is no known workaround at this time.


All users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-2.2.1' All binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.2.1'

See Also

Plugin Details

Severity: High

ID: 25660

File Name: gentoo_GLSA-200707-02.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/07/03

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openoffice, p-cpe:/a:gentoo:linux:openoffice-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/07/02

Vulnerability Publication Date: 2007/05/22

Reference Information

CVE: CVE-2007-0245, CVE-2007-2754

OSVDB: 35378, 36509

GLSA: 200707-02

CWE: 119