CVE-2007-0245

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Heap-based buffer overflow in OpenOffice.org (OOo) 2.2.1 and earlier allows remote attackers to execute arbitrary code via a RTF file with a crafted prtdata tag with a length parameter inconsistency, which causes vtable entries to be overwritten.

References

ftp://patches.sgi.com/support/free/security/advisories/20070602-01-P.asc

http://osvdb.org/35378

http://secunia.com/advisories/25648

http://secunia.com/advisories/25650

http://secunia.com/advisories/25673

http://secunia.com/advisories/25705

http://secunia.com/advisories/25862

http://secunia.com/advisories/25894

http://secunia.com/advisories/25905

http://secunia.com/advisories/26010

http://secunia.com/advisories/26022

http://secunia.com/advisories/26476

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102917-1

http://sw.openoffice.org/source/browse/sw/sw/source/filter/rtf/swparrtf.cxx?rev=1.67

http://www.debian.org/security/2007/dsa-1307

http://www.gentoo.org/security/en/glsa/glsa-200707-02.xml

http://www.mandriva.com/security/advisories?name=MDKSA-2007:144

http://www.novell.com/linux/security/advisories/2007_37_openoffice.html

http://www.redhat.com/support/errata/RHSA-2007-0406.html

http://www.securityfocus.com/archive/1/471274/100/0/threaded

http://www.securityfocus.com/bid/24450

http://www.securitytracker.com/id?1018239

http://www.ubuntu.com/usn/usn-482-1

http://www.vupen.com/english/advisories/2007/2166

http://www.vupen.com/english/advisories/2007/2229

https://exchange.xforce.ibmcloud.com/vulnerabilities/34843

https://issues.rpath.com/browse/RPL-1570

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10002

Details

Source: MITRE

Published: 2007-06-12

Updated: 2018-10-16

Type: CWE-119

Risk Information

CVSS v2

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:openoffice:openoffice:*:*:*:*:*:*:*:* versions up to 2.2.1 (inclusive)

Tenable Plugins

View all (30 total)

IDNameProductFamilySeverity
107858Solaris 10 (x86) : 120190-23NessusSolaris Local Security Checks
high
107857Solaris 10 (x86) : 120186-23NessusSolaris Local Security Checks
high
107356Solaris 10 (sparc) : 120189-23NessusSolaris Local Security Checks
high
107355Solaris 10 (sparc) : 120185-23NessusSolaris Local Security Checks
high
67513Oracle Linux 3 / 4 : openoffice.org (ELSA-2007-0406)NessusOracle Linux Local Security Checks
high
60206Scientific Linux Security Update : openoffice.org on SL4.x, i386/x86_64NessusScientific Linux Local Security Checks
high
60205Scientific Linux Security Update : openoffice.org on SL3.x i386/x86_64NessusScientific Linux Local Security Checks
high
29366SuSE 10 Security Update : OpenOffice_org (ZYPP Patch Number 3761)NessusSuSE Local Security Checks
high
28083Ubuntu 6.06 LTS / 6.10 / 7.04 : openoffice.org(2)/-amd64 vulnerability (USN-482-1)NessusUbuntu Local Security Checks
high
27665Fedora 7 : openoffice.org-2.2.0-14.11 (2007-0410)NessusFedora Local Security Checks
high
27139openSUSE 10 Security Update : OpenOffice_org (OpenOffice_org-3626)NessusSuSE Local Security Checks
high
27138openSUSE 10 Security Update : OpenOffice_org (OpenOffice_org-3530)NessusSuSE Local Security Checks
high
25697Mandrake Linux Security Advisory : openoffice.org (MDKSA-2007:144)NessusMandriva Local Security Checks
high
25660GLSA-200707-02 : OpenOffice.org: Two buffer overflowsNessusGentoo Local Security Checks
high
25552Sun OpenOffice.org RTF Parser prtdata Tag Buffer OverflowNessusWindows
high
25520RHEL 3 / 4 / 5 : openoffice.org (RHSA-2007:0406)NessusRed Hat Local Security Checks
high
25506Debian DSA-1307-1 : openoffice.org - heap overflowNessusDebian Local Security Checks
high
25495CentOS 3 / 4 / 5 : openoffice / openoffice.org (CESA-2007:0406)NessusCentOS Local Security Checks
high
23617Solaris 5.9 (x86) : 120190-19NessusSolaris Local Security Checks
high
23616Solaris 5.9 (x86) : 120186-19NessusSolaris Local Security Checks
high
23558Solaris 5.9 (sparc) : 120189-19NessusSolaris Local Security Checks
high
23557Solaris 5.9 (sparc) : 120185-19NessusSolaris Local Security Checks
high
23468Solaris 5.8 (x86) : 120190-19NessusSolaris Local Security Checks
high
23467Solaris 5.8 (x86) : 120186-19NessusSolaris Local Security Checks
high
23420Solaris 5.8 (sparc) : 120189-19NessusSolaris Local Security Checks
high
23419Solaris 5.8 (sparc) : 120185-19NessusSolaris Local Security Checks
high
22994Solaris 5.10 (x86) : 120190-19NessusSolaris Local Security Checks
high
22993Solaris 5.10 (x86) : 120186-19NessusSolaris Local Security Checks
high
22961Solaris 5.10 (sparc) : 120189-19NessusSolaris Local Security Checks
high
22960Solaris 5.10 (sparc) : 120185-19NessusSolaris Local Security Checks
high