Slackware 10.2 / 11.0 / current : php5 (SSA:2007-152-01)

medium Nessus Plugin ID 25373
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Slackware host is missing a security update.

Description

New php5 packages are available for Slackware 10.2, 11.0, and
-current to fix security issues. PHP5 was considered a test package in Slackware 10.2, and an 'extra' package in Slackware 11.0. If you are currently running PHP4 you may wish to stick with that, as upgrading to PHP5 will probably require changes to your system's configuration and/or web code.

Solution

Update the affected php package.

See Also

http://www.nessus.org/u?b1911273

Plugin Details

Severity: Medium

ID: 25373

File Name: Slackware_SSA_2007-152-01.nasl

Version: 1.18

Type: local

Published: 6/4/2007

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:php, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.2, cpe:/o:slackware:slackware_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/1/2007

Vulnerability Publication Date: 4/7/2007

Reference Information

CVE: CVE-2007-1900, CVE-2007-2756, CVE-2007-2872

SSA: 2007-152-01

CWE: 189