FreeBSD : google-earth -- heap overflow in the KML engine (5c9a2769-5ade-11db-a5ae-00508d6a62df)

High Nessus Plugin ID 25050


The remote FreeBSD host is missing a security-related update.


JAAScois reports :

While processing KML/KMZ data Google Earth fails to verify its size prior to copying it into a fixed-sized buffer. This can be exploited as a buffer-overflow vulnerability to cause the application to crash and/or to execute arbitrary code.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 25050

File Name: freebsd_pkg_5c9a27695ade11dba5ae00508d6a62df.nasl

Version: $Revision: 1.21 $

Type: local

Published: 2007/04/19

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:google-earth, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/10/14

Vulnerability Publication Date: 2006/10/10

Reference Information

CVE: CVE-2006-7157

BID: 20464