PHP < 5.2.1 Multiple Vulnerabilities

High Nessus Plugin ID 24907


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 5.2.1. Such versions may be affected by several issues, including buffer overflows, format string vulnerabilities, arbitrary code execution, 'safe_mode' and 'open_basedir' bypasses, and clobbering of super-globals.


Upgrade to PHP version 5.2.1 or later.

See Also

Plugin Details

Severity: High

ID: 24907

File Name: php_5_2_1.nasl

Version: 1.27

Type: remote

Family: CGI abuses

Published: 2007/04/02

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2007/02/08

Vulnerability Publication Date: 2006/12/09

Reference Information

CVE: CVE-2006-6383, CVE-2007-0905, CVE-2007-0906, CVE-2007-0907, CVE-2007-0908, CVE-2007-0909, CVE-2007-0910, CVE-2007-0988, CVE-2007-1376, CVE-2007-1380, CVE-2007-1383, CVE-2007-1452, CVE-2007-1453, CVE-2007-1454, CVE-2007-1700, CVE-2007-1701, CVE-2007-1824, CVE-2007-1825, CVE-2007-1835, CVE-2007-1884, CVE-2007-1885, CVE-2007-1886, CVE-2007-1887, CVE-2007-1889, CVE-2007-1890, CVE-2007-4441, CVE-2007-4586

BID: 21508, 22496, 22805, 22806, 22862, 22922, 23119, 23120, 23219, 23233, 23234, 23235, 23236, 23237, 23238

CWE: 20, 119, 189, 399