CVE-2007-1454

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/filter in PHP 5.2.0, when FILTER_SANITIZE_STRING is used with the FILTER_FLAG_STRIP_LOW flag, does not properly strip HTML tags, which allows remote attackers to conduct cross-site scripting (XSS) attacks via HTML with a '<' character followed by certain whitespace characters, which passes one filter but is collapsed into a valid tag, as demonstrated using %0b.

References

http://secunia.com/advisories/25056

http://secunia.com/advisories/25062

http://www.debian.org/security/2007/dsa-1283

http://www.mandriva.com/security/advisories?name=MDKSA-2007:090

http://www.novell.com/linux/security/advisories/2007_32_php.html

http://www.php-security.org/MOPB/MOPB-18-2007.html

http://www.securityfocus.com/bid/22914

Details

Source: MITRE

Published: 2007-03-14

Updated: 2008-09-05

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:5.2.0:*:*:*:*:*:*:*

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
37164Mandrake Linux Security Advisory : php (MDKSA-2007:090)NessusMandriva Local Security Checks
high
27150openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-3289)NessusSuSE Local Security Checks
high
25100Debian DSA-1283-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
24907PHP < 5.2.1 Multiple VulnerabilitiesNessusCGI abuses
high