PHP < 4.4.5 Multiple Vulnerabilities

high Nessus Plugin ID 24906

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 4.4.5. Such versions may be affected by several issues, including buffer overflows, format string vulnerabilities, arbitrary code execution, 'safe_mode' and 'open_basedir' bypasses, and clobbering of super-globals.

Solution

Upgrade to PHP version 4.4.5 or later.

See Also

http://www.php.net/releases/4_4_5.php

Plugin Details

Severity: High

ID: 24906

File Name: php_4_4_5.nasl

Version: 1.27

Type: remote

Family: CGI abuses

Published: 4/2/2007

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2/9/2007

Exploitable With

Metasploit (PHP 4 unserialize() ZVAL Reference Counter Overflow (Cookie))

Reference Information

CVE: CVE-2006-4625, CVE-2007-0905, CVE-2007-0906, CVE-2007-0907, CVE-2007-0908, CVE-2007-0909, CVE-2007-0910, CVE-2007-0988, CVE-2007-1286, CVE-2007-1376, CVE-2007-1378, CVE-2007-1379, CVE-2007-1380, CVE-2007-1700, CVE-2007-1701, CVE-2007-1777, CVE-2007-1825, CVE-2007-1835, CVE-2007-1884, CVE-2007-1885, CVE-2007-1886, CVE-2007-1887, CVE-2007-1890

BID: 22496, 22805, 22806, 22833, 22862, 23119, 23120, 23169, 23219, 23233, 23234, 23235, 23236

CWE: 20, 399