Squid < 2.6.STABLE7 Multiple Remote DoS

Medium Nessus Plugin ID 24870


The remote proxy server is affected by multiple denial of service vulnerabilities.


Two vulnerabilities have been reported in Squid, which can be exploited by malicious people to cause a denial of service.


Upgrade to squid 2.6.STABLE7 or newer.

See Also


Plugin Details

Severity: Medium

ID: 24870

File Name: squid_cdos.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Firewalls

Published: 2007/03/20

Modified: 2016/05/12

Dependencies: 10195

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2006/12/11

Reference Information

CVE: CVE-2007-0247, CVE-2007-0248

BID: 22079, 22203

OSVDB: 32823, 39839

CWE: 399