SUSE-SA:2006:043: apache,apache2

High Nessus Plugin ID 24423


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2006:043 (apache,apache2).

The following security problem was fixed in the Apache and Apache 2 web servers:

mod_rewrite: Fix an off-by-one security problem in the ldap scheme handling. For some RewriteRules this could lead to a pointer being written out of bounds. Depending on stack alignment this could be used to potentially execute code.

The mod_rewrite module is not enabled per default in our packages.

This problem is tracked by the Mitre CVE ID CVE-2006-3747.

A more detailed description of this problem is available in:

For SUSE Linux 10.0, 10.1 and SUSE Linux Enterprise 10 additionally a old bug was fixed that we missed to forward port to the Apache 2.2 packages:

mod_imap: Fixes a cross-site-scripting bug in the imagemap module.
This issue is tracked by the Mitre CVE ID CVE-2005-3352.


Plugin Details

Severity: High

ID: 24423

File Name: suse_SA_2006_043.nasl

Version: $Revision: 1.5 $

Agent: unix

Published: 2007/02/18

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list