FreeBSD : fetchmail -- TLS enforcement problem/MITM attack/password exposure (5238ac45-9d8c-11db-858b-0060084a00e5)

High Nessus Plugin ID 23987


The remote FreeBSD host is missing a security-related update.


Matthias Andree reports :

Fetchmail has had several longstanding password disclosure vulnerabilities.

- sslcertck/sslfingerprint options should have implied 'sslproto tls1' in order to enforce TLS negotiation, but did not.

- Even with 'sslproto tls1' in the config, fetches would go ahead in plain text if STLS/STARTTLS wasn't available (not advertised, or advertised but rejected).

- POP3 fetches could completely ignore all TLS options whether available or not because it didn't reliably issue CAPA before checking for STLS support - but CAPA is a requisite for STLS. Whether or not CAPAbilities were probed, depended on the 'auth' option. (Fetchmail only tried CAPA if the auth option was not set at all, was set to gssapi, kerberos, kerberos_v4, otp, or cram-md5.)

- POP3 could fall back to using plain text passwords, even if strong authentication had been configured.

- POP2 would not complain if strong authentication or TLS had been requested.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 23987

File Name: freebsd_pkg_5238ac459d8c11db858b0060084a00e5.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2007/01/08

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:fetchmail, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/01/06

Vulnerability Publication Date: 2007/01/04

Reference Information

CVE: CVE-2006-5867