FreeBSD : drupal -- multiple vulnerabilities (3d8d3548-9d02-11db-a541-000ae42e9b93)

Medium Nessus Plugin ID 23986


The remote FreeBSD host is missing one or more security-related updates.


The Drupal security team reports :

A few arguments passed via URLs are not properly sanitized before display. When an attacker is able to entice an administrator to follow a specially crafted link, arbitrary HTML and script code can be injected and executed in the victim's session. Such an attack may lead to administrator access if certain conditions are met.

The way page caching was implemented allows a denial of service attack. An attacker has to have the ability to post content on the site. He or she would then be able to poison the page cache, so that it returns cached 404 page not found errors for existing pages.

If the page cache is not enabled, your site is not vulnerable. The vulnerability only affects sites running on top of MySQL.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 23986

File Name: freebsd_pkg_3d8d35489d0211dba541000ae42e9b93.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2007/01/08

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:drupal, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/01/05

Vulnerability Publication Date: 2007/01/05

Reference Information

CVE: CVE-2007-0136