FreeBSD : ImageMagick -- SGI Image File heap overflow vulnerability (18e3a5be-81f9-11db-95a2-0012f06707f0)

High Nessus Plugin ID 23758


The remote FreeBSD host is missing one or more security-related updates.


SecurityFocus reports about ImageMagick :

ImageMagick is prone to a remote heap-based buffer-overflow vulnerability because the application fails to properly bounds-check user-supplied input before copying it to an insufficiently sized memory buffer.

Exploiting this issue allows attackers to execute arbitrary machine code in the context of applications that use the ImageMagick library.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 23758

File Name: freebsd_pkg_18e3a5be81f911db95a20012f06707f0.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/12/04

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ImageMagick, p-cpe:/a:freebsd:freebsd:ImageMagick-nox11, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/12/02

Vulnerability Publication Date: 2006/11/14

Reference Information

CVE: CVE-2006-5868

BID: 21185