FreeBSD : asterisk -- remote heap overwrite vulnerability (1c0def84-5fb1-11db-b2e9-0008c79fa3d2)

High Nessus Plugin ID 22884


The remote FreeBSD host is missing one or more security-related updates.


Adam Boileau of reports :

The Asterisk Skinny channel driver for Cisco SCCP phones ( incorrectly validates a length value in the packet header. An integer wrap-around leads to heap overwrite, and arbitrary remote code execution as root.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 22884

File Name: freebsd_pkg_1c0def845fb111dbb2e90008c79fa3d2.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2006/10/20

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:asterisk, p-cpe:/a:freebsd:freebsd:asterisk-bristuff, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2006/10/20

Vulnerability Publication Date: 2006/10/17