FreeBSD : dokuwiki -- multiple vulnerabilities (450b76ee-5068-11db-a5ae-00508d6a62df)

High Nessus Plugin ID 22489


The remote FreeBSD host is missing one or more security-related updates.


Secunia reports :

Some vulnerabilities have been reported in DokuWiki, which can be exploited by malicious people to cause a DoS (Denial of Service) or potentially compromise a vulnerable system.

Input passed to the 'w' and 'h' parameters in lib/exec/fetch.php is not properly sanitised before being passed as resize parameters to the 'convert' application. This can be exploited to cause a DoS due to excessive CPU and memory consumption by passing very large numbers, or to inject arbitrary shell commands by passing specially crafted strings to the 'w' and 'h' parameter.

Successful exploitation requires that the '$conf[imconvert]' option is set.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 22489

File Name: freebsd_pkg_450b76ee506811dba5ae00508d6a62df.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/10/02

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:dokuwiki, p-cpe:/a:freebsd:freebsd:dokuwiki-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2006/09/30

Vulnerability Publication Date: 2006/09/26

Reference Information

CVE: CVE-2006-5098, CVE-2006-5099

Secunia: 22192, 22199